Upgrade failed 🔗︎

If you get the following error in the logs of the Kafka operator, update your KafkaCluster CRD. This error typically occurs when you upgrade your Kafka operator to a new version, but forget to update the KafkaCluster CRD.

Error: UPGRADE FAILED: cannot patch "kafka" with kind KafkaCluster: KafkaCluster.kafka.banzaicloud.io "kafka" is invalid

The recommended way to upgrade the Kafka operator is to upgrade the KafkaCluster CRD, then update the Kafka operator. For details, see Upgrade the Kafka operator.